Frame Relay is a private networking technology similar to the concept of MPLS in that it is delivered in the “cloud”. Frame Relay can run over MPLS to obtain the benefits of traffic prioritization and management. Frame Relay has no quality of service (QoS) manageability and is largely being replaced by the more cost effective MPLS VPN Solutions.


MPLS is a protocol that uses packet labels to prioritize network packets to optimize network performance. If you have Quality of Service (QoS) sensitive applications such as VoIP, video conferencing, SAP, Oracle, Citrix or other real time applications running across your WAN then you should consider MPLS.
Picture
Requirement:
Configure IP address as per topology
CE1 should communicate to all mpls cloud via mpls
FRS1 should communicate to FRS2 and FRS3 via FROMPLS
There should not be any communication between FRS2 and FRS3

! CE1 Configuration

ip cef




mpls ip




mpls label protocol ldp





interface FastEthernet0/0
ip address 200.10.10.100 255.255.255.0
no shut

interface Serial0/0
ip address 11.1.1.1 255.255.255.252
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 11.1.1.0 0.0.0.3 area 0
network 200.10.10.0 0.0.0.255 area 0

ip route 0.0.0.0 0.0.0.0 11.1.1.2


! P1 Configuration

ip cef

mpls label protocol ldp

interface FastEthernet0/0
ip address 160.1.1.1 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

interface Serial0/0
ip address 11.1.1.2 255.255.255.0
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet0/1
ip address 160.1.1.9 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.13 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 11.1.1.0 0.0.0.3 area 0
network 160.1.1.0 0.0.0.3 area 0
network 160.1.1.8 0.0.0.3 area 0
network 160.1.1.12 0.0.0.3 area 0


! P3 Configuration

ip cef

mpls label protocol ldp

interface FastEthernet0/0
ip address 160.1.1.17 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet0/1
ip address 160.1.1.14 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.25 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 160.1.1.12 0.0.0.3 area 0
network 160.1.1.16 0.0.0.3 area 0
network 160.1.1.24 0.0.0.3 area 0


! PE2 Configuration

ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 15.15.15.15 255.255.255.255


interface FastEthernet0/0
ip address 160.1.1.21 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
no shut

interface FastEthernet0/1
ip address 160.1.1.26 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 15.15.15.15 0.0.0.0 area 0
network 160.1.1.20 0.0.0.3 area 0
network 160.1.1.24 0.0.0.3 area 0

connect FRS3-FRS1 Serial0/0 301 l2transport







xconnect 13.13.13.13 20 encapsulation mpls













mpls ldp router-id Loopback0 force




! P2 Configuration

ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 14.14.14.14 255.255.255.255

interface FastEthernet0/0
ip address 160.1.1.10 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay intf-type dce
no shut

interface FastEthernet0/1
ip address 160.1.1.5 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.18 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet2/0
ip address 160.1.1.22 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 14.14.14.14 0.0.0.0 area 0
network 160.1.1.4 0.0.0.3 area 0
network 160.1.1.8 0.0.0.3 area 0
network 160.1.1.16 0.0.0.3 area 0
network 160.1.1.20 0.0.0.3 area 0

connect FR2-FRS1 Serial0/0 201 l2transport xconnect 13.13.13.13 10 encapsulation mpls

mpls ldp router-id Loopback0 force


! PE1 Configuration


ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 13.13.13.13 255.255.255.255

interface FastEthernet0/0
ip address 160.1.1.2 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

interface Serial0/0
no ip address
encapsulation frame-relay
no shut
frame-relay intf-type dce

interface FastEthernet0/1
ip address 160.1.1.6 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

router ospf 10
network 13.13.13.13 0.0.0.0 area 0
network 160.1.1.0 0.0.0.3 area 0
network 160.1.1.4 0.0.0.3 area 0

connect FRS1-FRS2 Serial0/0 102 l2transport
xconnect 14.14.14.14 10 encapsulation mpls

connect FRS1-FRS3 Serial0/0 103 l2transport

xconnect 15.15.15.15 20 encapsulation mpls
mpls ldp router-id Loopback0 force


! FRS1 Configuration

interface Serial0/0
ip address 12.12.12.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 102
frame-relay interface-dlci 103
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0

!FRS2 Configuration

interface Serial0/0
ip address 19.19.19.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 201
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0


!FRS3 Configuration

interface Serial0/0
ip address 21.1.1.1 255.255.255.252
encapsulation frame-relay
frame-relay interface-dlci 301
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0
Configuration Explanation

Cisco's Express Forwarding (CEF) is an Layer 3 fastest switching technology by which Cisco router forwards packets from ingress to egress interfaces.
Note: This is a essential command

Globally enabling MPLS forwarding does not enable it on the router interfaces. You must enable MPLS forwarding on the interfaces as well as for the router.

Enable LDP protocol globally. MPLS Label Distribution Protocol (LDP) enables peer label switch routers (LSRs) in an MPLS network to exchange label binding information for supporting hop-by-hop forwarding in an MPLS network


Enabling interface with IP address



Enabling interface with IP address

Enabling MPLS LDP on interface
Enable Mpls IP on interface


Configuring OSPF for two networks



Default route



















































































command will enable your router to act as frame relay switch


Loopback interface ip. We are using this to enable our FR over MPLS communication through connect and xconnect commands given below




























In previous releases of AToM, the command used to configure AToM circuits was mpls l2 transport route. This command has been replaced with the xconnect command.

Applied command is telling to connect DLCI 301 and transport it via serial 0/0

The xconnect command is not supported on Frame Relay interfaces directly. For Frame Relay, the Xconnect is applied under the connectcommand specifying the DLCI to be used. we would directly apply xconnect directly to the customer interface, i.e under an ethernet interface or when the encapsulation is PPP or HDLC on a serial link. Frame relay encapsulation requires an alternate configuration.

command is telling to connect to router-id 13.13.13.13 having virtual circuit 20 using encapsulation type mpls

Enforcing MPLS router ID to be loopback 0 ip address. This will break LDP neighbor relationship and reestablish it


 
In this scenario; We are trying to built a topology in which four customers wanna communicate each other via frame relay cloud. Normally labs are done with one FR device but what about when we are working as a WAN service provider having so many devices in their cloud. Let's see how customers of TelcoRemote2 will communicate to customer of TelcoKHI.

We will built a tunnel for this purpose and use OSPF as a routing protocol between Cloud. Let's see detail
Picture
Requirement:

  • Configure all IP addresses as per topology
  • Assign DLCI's to all customers
  • Assign Route to all customers so that they will communicate each other seamlessly
  • Configure OSPF area 0 for network 10.1.1.0 and 20.1.1.0
  • Configure tunnel so that Remote customer can communicate to Site1, 2 and 3 customers.
  • Verify connectivity with
    ping command
    show frame-relay map
    show frame-relay route
    show frame-relay pvc
    debug frame-relay packet
    debug frame-relay pvc
    debug frame-relay event

!CustomerSite1 Configuration

interface Serial0/0
ip address 1.1.1.1 255.255.255.0
encapsulation frame-relay



frame-relay interface-dlci 101
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
no shut

!CustomerSite2 Configuration

interface Serial0/0
ip address 2.2.2.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 201
frame-relay interface-dlci 202
frame-relay interface-dlci 203
frame-relay interface-dlci 204
no shut

! CustomerSite3 Configuration

interface Serial0/0
ip address 3.3.3.3 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 301
frame-relay interface-dlci 302
frame-relay interface-dlci 303
frame-relay interface-dlci 304
no shut

! Telco remote2 Configuration

frame-relay switching




interface Serial0/0
no ip address

encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce

frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
frame-relay route 104 interface Tunnel0 401
no shut

interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
frame-relay route 203 interface Serial0/2 302
frame-relay route 204 interface Tunnel0 402
no shut

interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
frame-relay route 302 interface Serial0/1 203
frame-relay route 304 interface Tunnel0 403
no shut

interface fastethernet 0/0
ip address 10.1.1.1 255.255.255.252
no shut

interface tunnel 0
no ip address
tunnel source 10.1.1.1
tunnel destination 20.1.1.1

Router OSPF 10
network 10.1.1.0 0.0.0.3 area 0

! R7 Configuration

interface fastethernet 0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface fastethernet 0/1
ip address 20.1.1.2 255.255.255.252
no shut

Router OSPF 10
network 10.1.1.0 0.0.0.3 area 0
network 20.1.1.0 0.0.0.3 area 0


! Telco KHI Configuration

frame-relay switching

interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce

! Note both dlcis are same in all routes
frame-relay route 401 interface Tunnel0 401
frame-relay route 402 interface Tunnel0 402
frame-relay route 403 interface Tunnel0 403

no shut

interface fastethernet 0/0
ip address 20.1.1.1 255.255.255.252
no shut

interface tunnel 0
no ip address
tunnel source 20.1.1.1
tunnel destination 10.1.1.1

Router OSPF 10
network 20.1.1.0 0.0.0.3 area 0


! RemoteCustomer Configuration

interface Serial0/0
ip address 15.15.15.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 401
frame-relay interface-dlci 402
frame-relay interface-dlci 403
frame-relay interface-dlci 404
no shut



Configuration Explanation


Configuring IP on customer interface
encapsulation frame-relay command sets the frame encapsulation type. There are two types of Frame Relay encapsulations: Cisco and IETF. Cisco is the default.

We are putting many DLCI's to one physical serial interface.









See Site1 Explanation










See Site1 Explanation






This is a key command on FR switches on service provider side. Forget this command; Forget FR switching. Anyhow; If you try to configure interface type dce without this; you will get error.


As this interface word as a FR enabled interface; it donot require IP address.
Setting encapsulation type
Setting clock rate
FR switch interface must be DCE

This command is telling that DLCI 102, 103, 104 should route toward said interface



























Creating tunnel from source 10.1.1.1 (interface F0/0) to destination 20.1.1.1 (int F0/0)
































This is a key for tunneling Frame relay. Both DLCI's should be same in each command else you will find status Inactive